Strange characters when running chinese applications in Vista

My girlfriend is from Shanghai and loves to use her chinese apps:
QQ, popkart, some online DDR ripoff.

The only problem is that when we run the setup, or once in the app, all the characters are really strange, random circles and squiggles, not Chinese characters at all.
The solution thanks to
http://www.vistax64.com/vista-general/80694-chinese-application-not-showing-chinese-characters.html

is to change the system locale to Chinese.

You do this by going:
Control panel, regional settings.
Administrative tab
then the “Change system Locale” button. Change it to the appropriate setting (i chose Chinese PRC)

I’ve had no problems with my system after running like this for the last 2 months. All my games and applications still work fine and are displayed in english, but it is now able to display the correct chinese characters when requested.
(the only problem i have had are with Nvidia and intel driver installs, they detect the langauge setting and display the setup apps in chinese instead of English😉

By David Burela

Blogged with Flock

2 thoughts on “Strange characters when running chinese applications in Vista

  1. You can download AppLocale from Microsoft that allows changing the language for specific applications. It was meant for XP but you can install it on Vista, just need to turn off UAC.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s